producent programów komputerowych

61-517 Poznań, ul. Umińskiego 10

(061) 833-44-33, 833-93-03 fax. 833-93-02

soft@bhm.com.pl http://www.bhm.com.pl

HORNET

Kreator

DOKUMENTÓW


Wstęp

Opcja Kreator Dokumentów dostarcza użytkownikowi prosty edytor tekstu za pomocą którego można definiować dowolną postać dokumentów drukowanych przez program w postaci:

§ plików tekstowych wysyłanych na drukarkę igłową lub graficzną GDI – wersje DOS i Windows

§ plików graficznych w wersji Windows

§ sformatowanych w postacie plików html. Pliki html są to pliki tekstowe skonstruowane w specjalny sposób umożliwiający programom pracującym w środowisku okienek (np. środowisko Windows) na interpretację graficzną (razem z plikami graficznymi, muzyką, filmem itp.)

§ wiadomości poczty elektronicznej e-mail

Kreator dokumentów wyposażono w funkcje:

§ edytora tekstu,

§ deklaracja postaci tabeli,

§ deklaracji postaci rejestru,

§ opcji.

Edytor tekstu <F2>

Dokumenty tworzone za pomocą edytora tekstu mogą przyjmować dowolny format. Rozróżnić można dwa typy dokumentów deklarowanych przy pomocy edytora:

§ dokument prosty składający się wyłącznie z danych uzyskanych poprzez podstawienie zmiennych - występuje w sytuacji wydruków wykonywanych na podstawie danych z jednego zbioru np. dowody zapłaty Kp, Kw.

§ dokument złożony zawierający dane z wielu plików np. faktura, Wz, Pz itp. wymagający deklarowania kilku bloków składających się na dokument.

Deklaracja postaci tabeli <F3>:

Funkcja umożliwiająca precyzyjne określenie, jakie informacje (kolejność i ich format) znajdą się w bloku pozycji dokumentu. Deklaracja dotyczy wyłącznie dokumentów złożonych. Edycja przypomina ustalanie danych wyświetlanych na ekranie. Z listy pozycji należy wybrać te pozycje, które mają się znaleźć na dokumencie.

§ Kolumna pierwsza określa, w której linii znajdzie się pozycja. Możemy wpisać 0 - brak pozycji, 1 - pierwsza linia, 2 - druga linia, 3 - trzecia linia. W przedstawionym przykładzie nazwa asortymentu znajdzie się w pierwszej linii, cena sprzedaży w drugiej linii.

§ Druga kolumna określa kolejną pozycję w ramach linii. Nazwa asortymentu będzie w pierwszej linii jako pierwsza, cena sprzedaży w drugiej linii, pierwsza pozycja. Symbol magazynu drukowany będzie w pierwszej linii jako pozycja druga (za nazwą asortymentu)

§ pozycja SIZE określa wielkość (rozmiar) danych

§ opis kolumny pozwala na dowolnie deklarowany opis nagłówka pozycji

§ picture służy do określenia formatu przekazywanych danych.

Deklaracja postaci rejestru VAT <F4>

Funkcja pozwala określić dla dokumentów sprzedaży i zakupów dowolną postać rejestru VAT. Deklaracja podobna jak przy funkcji F3, ale dane dotyczą pliku nagłówka faktur SPN, a nie pozycji faktur SPP.

Opcje drukowania <F5>

Ustalenie dodatkowych parametrów wykorzystywanych przy drukowaniau.


Edytor tekstu

Edytor pozwala projektować wydruki dla następujących grup dokumentów:

Grupa dokumentów | Szablon | Rodzaj dokumentu
Kartoteki | ASN Kartoteka asortymentowa | Etykieta towarowa
 | ODN Kartoteka kontrahentów | Etykieta adresowa
 |  | Przelew
 | MDN Kartoteka miejsc dostaw | Etykieta adresowa
 | AWN Kartoteka wydatków | Etykieta towarowa
 | AUN Kartoteka usług | Etykieta towarowa
SPRZEDAŻ | SPN Faktury sprzedaży | FV faktura sprzedaży
 |  | FK faktura korygująca
 |  | PA paragon
 |  | PK paragon korygujący
 |  | RU faktura imienna
 |  | RK rachunek imienny korekta
 |  | Polecenie przelewu
 |  | Etykieta adresowa
 | RON Faktury sprzedaży | FV faktura sprzedaży
 |  | FK faktura korygująca
 |  | Polecenie przelewu
 |  | Etykieta adresowa
KOSZTY | KON faktury kosztowe | PZ Faktura zakupu
 |  | WF Faktura kosztowa
 |  | Polecenie przelewu
ZAKUPY KRAJOWE | ZON Faktury zakupu | Dokument PZ
 |  | Polecenie przelewu
FINANSOWO KSIĘGOWY | RPN polecenie księgowania | Dokument PK
 | PSN potwierdzenia sald | Dokument potwierdzenia sald
 | KSN Noty odsetkowe | Dokument noty odsetkowe
 | KWN Wezwania do zapłaty | Dokument wezwania do zapłaty
KSIEGA |  |
KASOWY BANKOWY ZALICZKI KOMPENSATY | KKN Raport kasowy | Dokument raport kasowy
 | KBN Raport bankowy | Dokument raport bankowy
 | KKP Pozycje raportów kasowych | BP bankowe polecenie wpłaty
 |  | BW bankowe polecenie wypłaty
 |  | KP dowód wpłaty
 |  | KW dowód wypłaty
ZAPŁATY | ZAN Dowody wpłat | BP bankowe polecenie wpłaty
 |  | BW bankowe polecenie wypłaty
 |  | KP dowód wpłaty
 |  | KW dowód wypłaty
 |  | Przelew
DOKUMENTY MAGAZYNOWE | MPN Dokumenty wydania Wz | Wydanie magazynowe Wz
 | MWN Dokument przyjęcia Pz | Przyjęcie magazynowe Pz
 | RWN Dokument przyjęcia Pz | Przyjęcie magazynowe Pz
 | MMN Dokument przesunięcia | Wydanie z magazynu Mm
 |  | Przyjęcie z magazynu Mm
 |  | Wydanie do produkcji WP
 |  | Przyjęcie z produkcji PP
 |  | Rozchód wewnętrzny RW
 |  | Przychód wewnętrzny PW
 |  | Przychód wewnętrzny PX
 |  | Rozchód wewnętrzny RX
INWENTURA | INN arkusze inwentaryzacyjne | Arkusz spisu z natury
 |  | Arkusz różnic
ZAMÓWIENIA | OFN Zamówienia odbiorcy | Potwierdzenie zamówienie do odbiorcy
 |  | Zlecenie transportu
 |  | Faktura Pro Forma
 | RFN Zamówienia odbiorcy | Potwierdzenie zamówienie do odbiorcy
 |  | Zlecenie transportu
 |  | Faktura Pro Forma
 | OHN Zamówienie do dostawcy | Dokument zamówienia
 |  | Potwierdzenie zamówienia
ZAKUPY IMPORT | EON Faktury zakupu | Faktura zakupu FI
 |  | Dowód dostawy Pz
 |  | Polecenie przelewu

Po wybraniu klawisza <F2> wyświetlają dostępne szablony, np. dla rejestru sprzedaży szablon SPN:

Tworzenie dokumentu:

1. Dokument rozpoczyna się znacznikiem początku bloku <dokument.ach> i kończy się znacznikiem </dokument.ach>

2. W ramach bloku całego dokumentu znajdować się powinny poszczególne bloki nagłówka, pozycji, sumy końcowej, zmiany strony i stopki. Ich kolejność jest dowolna.

3. W celu automatycznego wprowadzania znaczników do dokumentu zalecane jest korzystanie ze skorowidza <F2>

4. Zmienne do poszczególnych bloków wprowadza się wybierając ze skorowidza F1

5. Kody sterujące drukarką oraz znaczki formatujące dokument HTML wprowadza się za pomocą skorowidza <F3>

Przykładowo szablon dokumentu Faktura Vat może wyglądać następująco:

Lub widziany z poziomu wersji Windows:

Podczas przetwarzania dokumentu znaczniki będą usuwane, kody sterujące drukarką lub HTML zostaną zamienione na odpowiednie symbole, zmienne zostaną zamienione na dane.

Przykładowo:

^03 - kod sterujący drukarką oraz znacznik HTM

<$NRIDSPN/XXXXXXXXXXXX/C$> - zmienna oznaczająca dane pobierane z pola nridspn.

Każda zmienna rozpoczyna się od symboli <$ i kończy $>. Wewnątrz znajdują się informacje o nazwie pola, z którego dane mają zostać pobrane, formacie w jakim mają zostać wyświetlone oraz typie danych.

Format danych zależy od ustawienia picture w nawiasie / / i jest wielkością opcjonalną (jego brak powoduje, że wyświetlona informacja będzie zgodna z rozmiarem pola w bazie danych):

§ XXXX oznacza 4 dowolne znaki

§ - !!!!!!!!!! oznacza 10 znaków jako duże litery

§ - 9,999.99 oznacza kwotę z dwoma miejscami po przecinku (po kropce)

§ ##.##.## lub ####.##.## oznacza datę

ostatnia litera określa typ zwracanych danych :

§ C dane znakowe (charakter)

§ N dane numeryczne

§ D dane typu data


Klawisze funkcyjne

Wprowadzając zmienne do dokumentu należy wykorzystywać wbudowane funkcje ułatwiające edycję dokumentu:

§ <F1> wprowadzanie odwołań do pól z tabeli

§ <F2> wprowadzanie znaczników bloków

§

§ <F3> wprowadzanie kodów sterujących pracą drukarki, dokumentami HTML, poczty elektronicznej e-mail

§

§ <F4> wprowadzanie funkcji specjalnych

§

§ <F5> Wprowadzanie danych użytkownika systemu – płatnika

§

§ <F6> wprowadzanie kodów styli formatu HTML

Przykładowy plik tekstowy ACH na podstawie którego system formatuje wydruki:

<dokument.ACH>

<naglowek.ACH>

^01^02^03SPRZEDAWCA : <$Alltrim(gcNazwa1)//C$>                          Strona <$_nStrona()/XXXXXXX/C$>

             <$gcKodPoc//C$> <$alltrim(gcMiejsc)//C$>   ul. <$alltrim(gcUlica)//C$> <$alltrim(gcDom)//C$>

^04NIP
:<$zua->DIPL01/XXXXXXXXXXXXX/C$>REGON
:<$zua->DIPL02/XXXXXXXXX/C$>Numer telefonu
:<$zua->ASZP07/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

Numer rachunku bankowego    :<$TRIM(zua->BANK00)/C$> <$zua->BANKPP//C$> <$zua->BANK01//C$> <$zua->BANK02//C$>

Adres poczty elektronicznej :<$zua->ASZP09/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

   ˛04

^07^03                                        NABYWCA:

FAKTURA VAT <$Substr(ODN->NAZWA1,1,50)//C$>

  Nr: <$SUBSTR(DOKUMFA,1,8)/C$>W0H^07            ^02^04^12<$Substr(ODN->NAZWA2,1,50)//C$>^13^07^03

                                        ul.<$alltrim(ODN->ULICA)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

      ORYGINAŁ / KOPIA                <$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                                        NIP : <$ODN->NIP/XXXXXXXXXXXXX/C$>

MAGAZYN         :<$MAGAZYN/XX/C$>

Sposób zapłaty  :<$SPPLA(KODWPLATY)/XXXXXXXXXXXX/C$>         Data Sprzedaży   :<$DATFAK/##.##.##/D$>

Termin zapłaty  :<$TERMINFA/##.##.##/D$>           Data Wystawienia :<$DDOWOD/##.##.##/D$>

^02^04

</naglowek.ACH>

<pozycje.ACH>

-----------------------------------------------------------------------------------------------------------------------------

   Lp.»Nazwa asortymentu                            »Jed   » Ilość   »CenaPrzedRab   » CenSprzedaż   »     Wartość   »VAT   »

       Opis                                                 »Nr delegacji           »%Raba   »

-----------------------------------------------------------------------------------------------------------------------------

<NEXT:2>

<$NAZWAAS/TX_X50/C$><$JEDN/TX_X3/C$><$ROZCHOD/999.99/N$>  <$CENANETTO/TX_N092/N$>  <$CENAREAL()/TX_N092/N$>  <$WARNET()/TX_N092/N$><$TAX()/TX_N03/C$>

<$NAZWA2/TX_X50/C$><$NAZWA3/TX_X12/C$>        <$PROCRAB/TX_N52/N$>

-----------------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<sumafaktury.ACH>

-----------------------------------------------------------------------------------------------------------------------------

                                                                                <$WARNET/999,999.99  /N$>

----------------------------------------------------------------------------------------------------------------------------

</sumafaktury.ACH>

<NAGLOWEKSTRONY.ACH>

^02^03SPRZEDAWCA : <$Alltrim(gcNazwa1)//C$>                          Strona <$_nStrona()/XXXXXXX/C$>

             <$gcKodPoc//C$> <$alltrim(gcMiejsc)//C$>   ul. <$alltrim(gcUlica)//C$> <$alltrim(gcDom)//C$>

             ^04NIP :<$zua->DIPL01/XXXXXXXXXXXXX/C$>REGON :<$zua->DIPL02/XXXXXXXXX/C$>

^03^05     FAKTURA VAT MP nr : <$SUBSTR(DOKUMFA,1,8)/C$>^04^06

</NAGLOWEKSTRONY.ACH>

<SUMA.ACH>

<$as_sumavat()/C$>

</SUMA.ACH>

<STOPKA.ACH>

^03UDZIELONO RABATU W KWOCIE NETTO :<$RABATSPN()/99,999,999.99/N$>

^12

ZAPŁACONO  :<$ZAP0112()/99,999,999.99/N$>

DO ZAPŁATY :<$SALDO()/99,999,999.99/N$>

^13^04^05

Podpis osoby upoważnionej do odbioru faktury VAT                 OSOBA UPOWAZNIONA DO WYSTAWIENIA FAKTURY VAT

<$ODN->NAZWDOK/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

.......................................                        <$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXX/C$>

  PRZYJĘCIE FAKTURY JEST TRAKTOWANE JAKO UZNANIE WIERZYTELNOŚCI W TERMINIE.

  OD NIETERMINOWEJ PŁATNOŚCI NALICZANE BĘDĄ ODSETKI.

  DO MOMENTU CAŁKOWITEJ ZAPŁATY ZA FAKTURĘ WW. TOWARY HANDLOWE POZOSTAJĄ WŁASNOŚCIĄ SPRZEDAWCY.

                         ZAPRASZAMY OD PONIEDZIAŁKU DO PIATKU W GODZ. 8.00-17.00

</stopka.ACH>

<KONIECSTRONY.ACH>

^20

</KONIECSTRONY.ACH>

<SYSTEM.ACH>

</SYSTEM.ACH>

</dokument.ACH>


Bloki dokumentów ACH

Jak wyróżniono w przedstawionym przykładzie w dokumencie występują pewne bloki informacji. Każdy blok ujęty jest w opis rozpoczynający i kończący blok. Znakiem rozpoczynającym jest nazwa ujęta w nawias <>, znakiem kończącym jest ta sama nazwa ujeta w nawias <> oraz dodatkowo jako znak poprzedzający nazwę (czyli zaraz za znakiem <) symbol /

Przykładowo:

rozpoczynający blok | Kończący blok
<dokument.ACH> | </dokument.ACH>
<naglowek.ACH> | </naglowek.ACH>
<stopka.ACH> | </stopka.ACH>

Poniżej przedstawiono opis bloków wykorzystywanych w dokumentach wraz z krótką charakteryst


Dokument.ACH

Najważniejszy blok występujący w każdym dokumencie, określa w jakim miejscy rozpoczyna się i kończy blok dokumentu interpretowany przez system. Wszystkie zapisy występujące przed <dokument.ACH> oraz wszystkie zapisy występując po </dokument.ACH> będą ignorowane.


Naglowek.ACH

Blok oznaczający częśc nagłówkową rozbudowanych dokumentów takich jak faktury, rachunki, dokumenty magazynowe itp. Przykładowo:

<naglowek.ACH>

^01^02^03SPRZEDAWCA : <$Alltrim(gcNazwa1)//C$>                          Strona <$_nStrona()/XXXXXXX/C$>

             <$gcKodPoc//C$> <$alltrim(gcMiejsc)//C$>   ul. <$alltrim(gcUlica)//C$> <$alltrim(gcDom)//C$>

^04NIP
:<$zua->DIPL01/XXXXXXXXXXXXX/C$>REGON
:<$zua->DIPL02/XXXXXXXXX/C$>Numer telefonu
:<$zua->ASZP07/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

Numer rachunku bankowego
:<$TRIM(zua->BANK00)/XXXXXXXXXXXXXXXXXXX/C$>
<$zua->BANKPP//C$> <$zua->BANK01//C$>
<$zua->BANK02//C$>

Adres poczty elektronicznej :<$zua->ASZP09/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

^07^03                                        NABYWCA:

FAKTURA VAT      ^02^04^12<$Substr(ODN->NAZWA1,1,50)//C$>^13^07^03

  Nr: <$SUBSTR(DOKUMFA,1,8)/C$>W0H^07            ^02^04^12<$Substr(ODN->NAZWA2,1,50)//C$>^13^07^03

                                        ul.<$alltrim(ODN->ULICA)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

      ORYGINAŁ / KOPIA                <$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                                        NIP : <$ODN->NIP/XXXXXXXXXXXXX/C$>

MAGAZYN         :<$MAGAZYN/XX/C$>

Sposób zapłaty  :<$SPPLA(KODWPLATY)/XXXXXXXXXXXX/C$>         Data Sprzedaży   :<$DATFAK/##.##.##/D$>

Termin zapłaty  :<$TERMINFA/##.##.##/D$>           Data Wystawienia :<$DDOWOD/##.##.##/D$>

^02^04

</naglowek.ACH>


Pozycje.ACH

Blok dotyczący pozycji dokumentów, wypełniany jest w sposób automatyczny poprzez deklarację klawiszem <F3> układ tabeli, przykładowo:

<pozycje.ACH>

-----------------------------------------------------------------------------------------------------------------------------

Lp.»Nazwa asortymentu                               »Jed   » Ilość   »CenaPrzedRab   » CenSprzedaż   »     Wartość   »VAT   »

    Opis                                                 »Nr delegacji           »%Raba   »

-----------------------------------------------------------------------------------------------------------------------------

<NEXT:2>

<$NAZWAAS/TX_X50/C$><$JEDN/TX_X3/C$><$ROZCHOD/999.99/N$>  <$CENANETTO/TX_N092/N$>  <$CENAREAL()/TX_N092/N$>  <$WARNET()/TX_N092/N$><$TAX()/TX_N03/C$>

<$NAZWA2/TX_X50/C$><$NAZWA3/TX_X12/C$>        <$PROCRAB/TX_N52/N$>

-----------------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>


Suma.ACH

Podsumowanie dokumentu faktury, przykładowo funkcja as_sumavat() drukuje podsumowanie wartości netto, vat i brutto w zależności od pozycji dokumentu.

<SUMA.ACH>

<$as_sumavat()/C$>

</SUMA.ACH>


Stopka.ACH

Stopka dokumentu, przykładowo:

<STOPKA.ACH>

^03UDZIELONO RABATU W KWOCIE NETTO :<$RABATSPN()/99,999,999.99/N$>

^12

ZAPŁACONO  :<$ZAP0112()/99,999,999.99/N$>

DO ZAPŁATY :<$SALDO()/99,999,999.99/N$>

^13^04^05

Podpis osoby upoważnionej do odbioru faktury VAT                 OSOBA UPOWAZNIONA DO WYSTAWIENIA FAKTURY VAT

<$ODN->NAZWDOK/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

.......................................                        <$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXX/C$>

  PRZYJĘCIE FAKTURY JEST TRAKTOWANE JAKO UZNANIE WIERZYTELNOŚCI W TERMINIE.

  OD NIETERMINOWEJ PŁATNOŚCI NALICZANE BĘDĄ ODSETKI.

  DO MOMENTU CAŁKOWITEJ ZAPŁATY ZA FAKTURĘ WW. TOWARY HANDLOWE POZOSTAJĄ WŁASNOŚCIĄ SPRZEDAWCY.

                         ZAPRASZAMY OD PONIEDZIAŁKU DO PIATKU W GODZ. 8.00-17.00

</stopka.ACH>


Koniecstrony.ACH

Stopka strony, dla dokumentów które składają się z wielu stron, przykładowo wysyłamy rozkaz drukarki oznaczony kodem ^20, który oznacza rozkaz przejścia do nowej strony:

<KONIECSTRONY.ACH>

^20

</KONIECSTRONY.ACH>


Rejestr.ACH

Deklaracja dokumentu specjalnego jakim jest rejestr VAT


Sumarejestru.ACH

Suma dokumentu typu Rejestr VAT


System.ACH

Etykieta systemu HORNET, przykładowo blok nie zawiera żadnej informacji, nic nie będzie drukowane:

<SYSTEM.ACH>

</SYSTEM.ACH>


Poczatekstrony.ACH

Początek strony dokumentów wielostronicowych, blok wykorzystywany jest na każdej kolejnej stronie oprócz pierwszej.


Sumafaktury.ACH

Podsumowanie faktury, przykładowo:

<sumafaktury.ACH>

-----------------------------------------------------------------------------------------------------------------------------                                                                                                      <$WARNET/999,999.99  /N$>

-----------------------------------------------------------------------------------------------------------------------------

</sumafaktury.ACH>


Funkcji.ACH

Blok funkcji specjalnych


Naglowekstrony.ACH

Nagłówek dokumentów wielostronicowych, blok wykorzystywany jest na każdej kolejnej stronie oprócz pierwszej. Przykładowo:

<NAGLOWEKSTRONY.ACH>

^02^03SPRZEDAWCA : <$Alltrim(gcNazwa1)//C$>                          Strona <$_nStrona()/XXXXXXX/C$>

             <$gcKodPoc//C$> <$alltrim(gcMiejsc)//C$>   ul. <$alltrim(gcUlica)//C$> <$alltrim(gcDom)//C$>

             ^04NIP :<$zua->DIPL01/XXXXXXXXXXXXX/C$>REGON :<$zua->DIPL02/XXXXXXXXX/C$>

^03^05     FAKTURA VAT MP nr : <$SUBSTR(DOKUMFA,1,8)/C$>^04^06

</NAGLOWEKSTRONY.ACH>


Sprawozdania.ACH

Blok wykorzystywany w dokumentach typu sprawozdania


Sumafaktubr.ACH

Blok podumowania faktury wystawianej w cenach brutto, rachunki imienne


Deklaracja postaci tabeli

Deklaracja ta ma na celu określenie dla dokumentów wielopozycyjnych postaci tabeli drukowanej jako pozycje ze zbioru pozycji. Standardowym przykładem takiego dokumentu jest faktura sprzedaży, zawierająca w środku tabelę z pozycjami sprzedaży (towarem lub usługami)

Funkcja <F3> udostępnia parametry podobne do deklaracji w kreatorze rejestrów. Dla każdej pozycji dostępnej w rejestrze możemy zadeklarować osiem parametrów:

1. UKŁAD PIONOWY Określenie numeru pozycji w linii tabeli, można określić czy dana informacja ma być w pierwszej, drugiej lub trzeciej linii. Deklaracja ta odpowiedzialna jest za układ tabeli, która może drukować tylko jeden wiersz dla każdej pozycji sprzedaży, dwa lub trzy wiersze dla każdej pozycji sprzedaży.

2. UKŁAD POZIOMY Pozycja określa położenie poziome, im niższy numer tym bardziej od lewej strony dokumentu znajdzie się dana informacja.

3. Wielkość, określa z ilu znaków ma składać się informacja na wydruku. Jeżeli nazwa asortymentu w komputerze zadeklarowana jest na 50 znaków, to nie jesteśmy zmuszani do drukowania pełnej 50 znakowej nazwy, możemy podać, cyfrę 30, określającą, że drukowane mają być tylko pierwsze 30 znaków. (istnieje możliwość zmiany deklaracji informacji opcją F2 edytor dokumentu i zadeklarować inny układ np. drukować tylko 10 znaków rozpoczynając od 20.-> więcej na ten temat w funkcjach zaawansowanych)

4. Opis – słowna deklaracja kolumny tabeli

5. Format danych tzw. Picture pozwalający definiować postać wysyłanych danych

6. Suma -> parametr ustawiony na T oznacza, że dana informacja podlega sumowaniu, ustawienie na N, nie podlega. Parametr ma znaczenie wyłącznie dla pozycji numerycznych, w pozostałych nie ma znaczenia. Pewne pola numeryczne ma sens sumować np. wartość, ilość ogółem, natomiast inne pola numeryczne poddane sumowaniu dają informacje bez znaczenia, np. suma cen jednostkowych.

7. Kod sterujący wydrukiem (drukarka lub HTML) wysyłany przed informacją pozwala formatować wydruk danej pozycji

8. Kod sterujący wysyłany po danej informacji, zwykle odwołujący formatowanie wysyłane w poprzednim punkcie.

W celu aktywowania ustawień zadeklarowanych funkcją <F3> deklaracja tabeli należy uruchomić edytor dokumentów <F2> i zapisać zmiany w dokumencie <F9>. Prawidłowe działanie szablonu dokumentu należy sprawdzić w programie najlepiej poprzez podgląd dokumentu <Alt><F1> (lub <Alt><F2>).

Przykładowo:

<pozycje.ACH>

-----------------------------------------------------------------------------------------------------------------------------

Lp.»Nazwa asortymentu                               »Jed   » Ilość   »CenaPrzedRab   » CenSprzedaż   »     Wartość   »VAT   »

    Opis                                                 »Nr delegacji           »%Raba   »

-----------------------------------------------------------------------------------------------------------------------------

<NEXT:2>

<$NAZWAAS/TX_X50/C$><$JEDN/TX_X3/C$><$ROZCHOD/999.99/N$>  <$CENANETTO/TX_N092/N$>  <$CENAREAL()/TX_N092/N$>  <$WARNET()/TX_N092/N$><$TAX()/TX_N03/C$>

<$NAZWA2/TX_X50/C$><$NAZWA3/TX_X12/C$>        <$PROCRAB/TX_N52/N$>

-----------------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<pozycje.ACH>

-----------------------------------------------------------------------------------------------------------------------------

>>Lp.   <<>>VAT<<>>Jed       <<>>Ilość        <<>>CenaPrzedRab <<>>Wartość      <<>>CenSprzedaż

<<>>Nazwa asortymentu                       <<>>%Rabat<<>>Nr delegacji                                      <<>>Opis<<

-----------------------------------------------------------------------------------------------------------------------------

<NEXT:2>

<${SPP}:C:/TX_N03/  $><${SPP}:C:/TX_X3/  $><${SPP}:N:/999.99/  $><${SPP}:N:/TX_N092/  $><${SPP}:N:/TX_N092/  $><${SPP}:N:/TX_N092/  $><${SPP}:C:/TX_X50/  $>

<${SPP}:N:/TX_N52/  $><${SPP}:C:/TX_X12/  $><${SPP}:C:/TX_X50/  $>

-----------------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>


Deklaracja postaci rejestru

W celu ułatwienia obsługi wydruków standardowych, powtarzalnych można użytkownikom zdefiniować szablony dotyczące całego rejestru dokumentów, (w poprzednim punkcie deklarowaliśmy postać tabeli znajdującej się wewnątrz jednego dokumentu- dotyczącego jednego dokumentu) czyli wielu dokumentów.

Przykładem najlepiej odwzorowującym tego typu potrzeby jest rejestr sprzedaży VAT, do drukowania którego jest zobligowany każdy podatnik. Ustawienie szablonu do drukowania takiego rejestru, udostępnia użytkownikowi gotowe rozwiązanie. Praca jest dwuetapowa, polega na określeniu rodzaju informacji, które mają się znaleźć w rejestrze F4 oraz na ustaleniu układu wydruku poprzez edytor dokumentów F2. Z pozycji funkcji F4 możemy deklarować następujący zakres informacji:

1. UKŁAD PIONOWY Określenie numeru pozycji w linii tabeli, można określić czy dana informacja ma być w pierwszej, drugiej lub trzeciej linii. Deklaracja ta odpowiedzialna jest za układ tabeli, która może drukować tylko jeden wiersz dla każdej pozycji sprzedaży, dwa lub trzy wiersze dla każdej pozycji sprzedaży.

2. UKŁAD POZIOMY Pozycja określa położenie poziome, im niższy numer tym bardziej od lewej strony dokumentu znajdzie się dana informacja.

3. Wielkość, określa z ilu znaków ma składać się informacja na wydruku. Jeżeli nazwa asortymentu w komputerze zadeklarowana jest na 50 znaków, to nie jesteśmy zmuszani do drukowania pełnej 50 znakowej nazwy, możemy podać, cyfrę 30, określającą, że drukowane mają być tylko pierwsze 30 znaków. (istnieje możliwość zmiany deklaracji informacji opcją F2 edytor dokumentu i zadeklarować inny układ np. drukować tylko 10 znaków rozpoczynając od 20.-> więcej na ten temat w funkcjach zaawansowanych)

4. Opis – słowna deklaracja kolumny tabeli

5. Format danych tzw. Picture pozwalający definiować postać wysyłanych danych

6. Suma -> parametr ustawiony na T oznacza, że dana informacja podlega sumowaniu, ustawienie na N, nie podlega. Parametr ma znaczenie wyłącznie dla pozycji numerycznych, w pozostałych nie ma znaczenia

7. Kod sterujący wydrukiem (drukarka lub HTML) wysyłany przed informacją pozwala formatować wydruk danej pozycji

Kod sterujący wysyłany po danej informacji, zwykle odwołujący formatowanie wysyłane w poprzednim punkcie.


Opcje dokumentu

Opcje dotyczące wydruków pozwalają określić ogólne informacje dotyczące dokumentów. Należy systemowi wskazać domyślne parametry wydruków:

1. Domyślny typ drukarki dla poszczególnych rodzajów dokumentów

2. Określić czy dana grupa użytkowników ma prawo dowolnie wybierać rodzaj drukarki

3. Określić sugerowaną liczbę egzemplarzy

4. Wskazać port drukarki

5. Ustalić długość strony (papieru) poprzez podanie liczby linii na wydruku na jedną stronę

6. W wersji windows okreslić rozmiar czcionki, użyty rodzaj FONTów, kolor podstawowy itp. W przykładzie poniżej wyświetlone jets pierwsze 11 parametrów, liczba całkowita wynosi 53 parametry dla szablonu sprzedazy SPN.


Funkcje specjalne szablonów dokumentów

W szablonach dokumentów można wykorzystywać specyficzne funkcje w celu uzyskania odpowiednich rezultatów wydruków.

KOD | Opis | Nazwa funkcji
0044 | Data bieżąca | Date()
0045 | Czas | Time()
0046 | Bieżący rok sprawozdawczy | _cYear()
0047 | Bieżący miesiąc sprawozdawczy | _cMonth()
0048 | Numer strony | _nStrona()
0183 | PETRO SumaCiezaru FAKTURA Funkcja drukuje sumę ciężaru pozycji znajdujących się na fakturze. Przykładowo fragment szablonu faktury: Ciężar <$_SumCiezFA()/999,999.99/N$>kg | _SumCiezFA()
0184 | PETRO SumaCiezaru WZ | _SumCiezWZ()
0211 | STIGA SumaObjeto FAKTURA Funkcja drukuje sumę objętości pozycji znajdujących się na fakturze. Przykładowo fragment szablonu faktury: Objętość:<$_SumObjeFA()/999,999.99/N$>m3 | _SumObjeFA()
0212 | STIGA SumaObjeto WZ | _SumObjeWZ()
0213 | STIGA SumaObjeto ZAMOWIENIE | _SumObjeZA()
0214 | PETRO SumaCiezaru ZAMOWIENIE | _SumCiezZA()
0241 | Ilosc KP | _iLoscKP()
0242 | Ilosc KW | _iLoscKW()
0243 | Ustawienie odczytu MDN z SPN Funkcja otwiera zbiór miejsc dostawy, dzięki czemu możemy w szablonie odwoływać się do zbioru MDN poprzez wskazanie aliasu i drukować informacje w nim zawarte. Przykład, fragment szablonu faktury sprzedaży: <$setODNMDN()/!/C$> miejsce dostawy:<$MDN->KODPOC/99-999/C$><$alltrim(MDN->MIEJSC)/C | SetODNMDN()
0441 | Kwota słownie | _Slownie()
0442 | Kwota brutto A % | _BruttoA()
0443 | Kwota brutto B % | _BruttoB()
0446 | Kwota brutto D % | _BruttoD()
0540 | Kwota słownie WARDEW | _SlownieDEW()
0556 | Drukowanie EMN w stopce FA | StopkaEMN()
0563 | Ustawienie odczytu BANK z SPN | SetBANKSPN()
0606 | Numer strony + 1 GAZETA | _nStrona2()
0794 | Kwota slownie w j.angielskim | _SlownieEng()
0895 | Drukowanie EMN w stopce ZAMOW | OFNStopkaEMN()
0904 | NazwaAS->APN w dokumentach ACH | ReadAPNDok()
0911 | MASZYNA->PMN w dokumentach ACH | ReadPMNDok()
0912 | SYMNORMY->NTN w dokumen. ACH | ReadNTNDok()
 | Funkcja drukuje podsumowanie dokumentu w układzie różnych stawek VAT znajdujących się na dokumencie. Przykładowo fragment szablonu faktury VAT: <suma.ACH> <$as_sumavat()/C$> </suma.ACH> | As_sumavat()
 | Funkcja drukuje wielkość rabatu ogółem wszystkich pozycji znajdujących się na fakturze, przykładowo fragment szablonu faktury: rabat w kwocie:<$RABATSPN()/99,999,999.99/N$> | Rabatspn()


Wzory szablonów dokumentów


Szablon SPN

<F3> układ tabeli

Typ:SPN Nazwa:FAKTURY SPRZEDALinia Pozyc.Wielk.Opis Format Suma KodSter

-----------------------------------------------------------------------

NAZWA :¦1 1 42 Nazwa asortymen XXXXXXXXXXXXXXX N

INDEKS :¦2 1 24 Indeks XXXXXXXXXXXXXXX N

SWW :¦2 2 41 PKWiU(SWW) XXXXXXXXXXXXXX N

JEDN :¦1 2 3 J.m. XXX N

CENANETTO :¦2 3 12 Netto 99,999,999.99 N

ROZCHOD :¦1 3 5 Ilość 999999999 T

RABAT :¦0 4 9 Raba 999,99.99 N

PROCRAB :¦2 4 5 %Raba 99.99 N

TAX :¦2 5 3 VAT 999 N

CENAREAL :¦1 5 12 Cena 999,999.99 N

WARNET :¦1 6 12 WartNetto 99,999,999.99 T

WARBRU :¦1 8 12 WartBrutto 99,999,999.99 N

F5 Atrybuty dokumentu

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦TAK

03 TABELA Ilość egz. :¦ 0

04 Port drukarki :¦

05 Podgląd (T/N)¦nie

06 Ilość wierszy :¦ 0

07 PRZELEW Ilość egz. :¦ 0

08 Port drukarki :¦

09 Podgląd (T/N)¦nie

10 Ilość wierszy :¦ 0

11 FAKTURA Ilość egz. :¦ 1

12 Port drukarki :¦1

13 Podgląd (T/N)¦TAK

14 Ilość wierszy :¦ 65

15 Wydruk au (T/N)¦TAK

16 WZ Ilość egz. :¦ 0

17 Port drukarki :¦

18 Podgląd (T/N)¦nie

19 Ilość wierszy :¦ 0

20 Wydruk au (T/N)¦nie

21 ETYKIETA Ilość egz. :¦ 0

22 Port drukarki :¦

23 Podgląd (T/N)¦nie

24 Ilość wierszy :¦ 0

25 RejestrVAT Ilość egz. :¦ 0

26 Port drukarki :¦

27 Podgląd (T/N)¦nie

28 Ilość wierszy :¦ 0

29 SFAKTURA Ilość egz. :¦ 0

30 Port drukarki :¦

31 Ilość wierszy :¦ 0

32 SETYKIETA Ilość egz. :¦ 0

33 Port drukarki :¦

34 Ilość wierszy :¦ 0

Faktura sprzedaży plik SPN001FV.ACH

Faktura sprzedaży korekta plik SPN001FK.ACH

<dokument.ACH>

<naglowek.ACH>

SPRZEDAWCA : BHM-Soft Paweł Podbielski

             <$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ul.<$alltrim(gcUlica)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> <$gcDom/XXXXX/C$>

Biuro Handlowe : 61-517 POZNAŃ, ul. Umińskiego 10

NIP :<$zua->DIPL01/XXXXXXXXXXXXX/C$>REGON :<$zua->DIPL02/XXXXXXXXXXXXXX/C$>Numer telefonu :<$zua->ASZP07/ /C$>

Adres poczty elektronicz :<$zua->ASZP09/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

Numer rachunku bankowego :PKO BP o.Środa Wlkp. 10204157-52878-270-1

^03FAKTURA KOREKTA VAT nr : <$DOKUMFA/XXXXXXXXXXXXXXX/C$>

^04

<$SPACE(50) /C$> ORYGINAŁ / KOPIA

Sposób zapłaty  :<$SPPLA(KODWPLATY)/XXXXXXXXXXXX/C$>       Data Sprzedaży   :<$DATFAK/##.##.##/D$>

Termin zapłaty  :<$TERMINFA/##.##.##/D$>  Data Wystawienia :<$DDOWOD/##.##.##/D$>

NABYWCA : <$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->KODPOC/99-999/C$> <$alltrim(MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ul.<$alltrim(ODN->ULICA)/C$>

    NIP :<$ODN->NIP/XXXXXXXXXXXXX/C$>ANALITYKA :<$ODN->NRIDODN/XXXXXXXXXXXX/C$>

</naglowek.ACH>

<pozycje.ACH>

-----------------------------------------------------------------------------------------------------------------------

    Lp. NAZWA ASORTYMENTU                                     Jed    ilość    CenSprzedaż     WARTOŚĆ         VAT

-----------------------------------------------------------------------------------------------------------------------

<NEXT:1>

<$NAZWAAS/C$><$JEDN/XXX/C$><$ROZCHOD/99999/N$><$CENAREAL()/999,999.99  /N$><$WARNET()/999,999.99  /N$><$TAX()/999/C$>

-----------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<poczatekstrony.ACH>

                                                      <$_nStrona()/XXXXXXX/C$>

</poczatekstrony.ACH>

<sumafaktury.ACH>

--------------------------------------------------------------------------------------------------------------------------

                                                             <$ROZCHOD/99999/N$>                <$WARNET/999,999.99  /N$>

--------------------------------------------------------------------------------------------------------------------------

</sumafaktury.ACH>

<koniecstrony.ACH>

^08

</koniecstrony.ACH>

<suma.ACH>

<$as_sumavat()/C$>

</suma.ACH>

<stopka.ACH>

Polecenie przelewu plik SPN00103.ACH

<dokument.ACH>

<naglowek.ACH>

--------------------------------------------------------------------------------------------------------------------

[2] POLECENIE PRZELEWU                                     A

|------------------------------|-----------------------------|

|      W CIEZAR RACHUNKU       |        NA DOBRO RACHUNKU    |

|------------------------------|-----------------------------|

|       NAZWA DLUZNIKA         |        NAZWA WIERZYCIELA    |

|------------------------------|-----------------------------|

|<$SUBSTR(gcNazwa1,1,26)/C$>   |<$SUBSTR(odn->nazwa1,1,25)/C$>|

|<$SUBSTR(gcNazwa2,1,26)/C$>   |<$substr(odn->nazwa2,1,25)/C$>|

|<$SUBSTR(gcMiejsc,1,26)/C$>   |<$SUBSTR(MIEJSC,1,25)/C$>    |

|<$SUBSTR(gcUlica ,1,26)/C$>   |<$SUBSTR(ULICA ,1,25)/C$>    |

|------------------------------|-----------------------------|

|w (BANKU)                     |w (BANKU)                    |

|<$PADR(zua->bank00,26)/C$>|<$PADR(odn->bank0,25)/C$>|

|<$PADR(zua->bank01+zua->bank02,26)/C$>|<$PADR(odn->bank1+odn->bank2,25)/C$>|

|<$PADR(zua->bank03+zua->bank04,26)/C$>|<$PADR(odn->bank3+odn->bank4,25)/C$>|

|------------------------------|-----------------------------|

|PL.KAS.:                      |KWOTA   :    <$VBrutto()/9,999,999.99/N$>|

|------------------------------|-----------------------------|

|DATA :                        |TYTULEM :                    |

|                              |                             |

|                              |z dnia :                     |

|------------------------------|-----------------------------|

|                              |          Stempel Banku      |

|                              |                             |

|   .......................    |                             |

|    pieczec zleceniodawcy     |                             |

|         i podpisy            |                             |

</naglowek.ACH>

</dokument.ACH>


Szablon KKN

F3 Układ tabeli

Typ:KKN Nazwa:RAPORT KASOWY Linia Pozyc.Wielk.Opis Format Suma KodSter

-----------------------------------------------------------------------

DOKUMZA :¦1 1 12 NRDOWODU XXXXXXXXXXXX N

NrFaktury :¦1 2 15 NrFaktury XXXXXXXXXXXXXXX N

NazwaSkrócona :¦1 3 25 NazwaSkrócona XXXXXXXXXXXXXXX N

TRESC :¦1 4 35 TRESC XXXXXXXXXXXXXXX N

WpłataWnPLN :¦1 7 10 OBROTY WN 999,999.99 N

WypłataMaPLN :¦1 8 10 OBROTY MA 999,999.99 N

F5 Atrybuty dokumenty

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦nie

03 RAPORT KASOWY Ilość egz. :¦ 1

04 Port drukarki :¦2

05 Podgląd (T/N)¦TAK

06 Ilość wierszy :¦ 60

Raport kasowy plik KKN00101.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02^03<$TRIM(gcNazwa1)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^04

^03<$TRIM(gcKodPoc)/XXXXXX/C$><$TRIM(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$><$TRIM(gcUlica)/ C$><$TRIM(gcDom)/XXXXX/C$>^04

                             <$_nStrona()/XXXXXXX/C$>

RAPORT KASOWY nr :^03<$SUBSTR(DOKUMRA,3,6)/XXXXXXXXXXXX/C$>^04

Data             :^03<$DDOWOD/##.##.##/D$> ^04

KASA             :^03<$SKASA/XX/C$>^04

SALDO POCZĄTKOWE :^03<$SALDOBO/99,999,999.99/N$>^04

OBROTY WN        :^03<$OBROTYWN/99,999,999.99/N$>^04

OBROTY MA        :^03<$OBROTYMA/99,999,999.99/N$>^04

SALDO KOŃCOWE    :^03<$SALDOBZ/99,999,999.99/N$>^04

</naglowek.ACH>

<pozycje.ACH>

----------------------------------------------------------------------------------------------------------------------------------

   Lp. NRDOWODU        NrFaktury          NazwaSkrócona                     TRESC                        OBROTY WN     OBROTY MA

----------------------------------------------------------------------------------------------------------------------------------

<NEXT:1>

<$DOKUMZA/TX_X12/C$><$DOKUMFA/TX_X15/C$><$SKROCO/TX_X30/C$><$TKONTO/TX_X30/C$>     <$WNPLN/TX_N092/N$><$MAPLN/TX_N092/N$>

----------------------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<stopka.ACH>

    Podpis kasjera  .....................................

                    <$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^20

</stopka.ACH>

</dokument.ACH>


Szablon KKP

F5 Atrybuty dokumentu

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦TAK

03 DOWÓD Ilość egz. :¦ 1

04 Port drukarki :¦2

05 Podgląd (T/N)¦TAK

06 Ilość wierszy :¦ 60

07 Wydruk au (T/N)¦TAK

Pozycje raportu kasowego, dowód KP plik KKP001KP.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02-----------------------------------------------------------------------------------------------------------

 <$Time()/XXXXXXXXXX/C$>

                                 ^05 DOWÓD WPŁATY KP nr :<$DOKUMZA/XXXXXXXXXXXX/C$>^06

  . . . . . . . . . . . . . .      Pokwitowanie

               pieczęć

                                 ^05 Dnia <$Date()/####.##.##/D$> ^06

 -----------------------------------------------------------------------------------------------------------

^03  OD KOGO^04 :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                 <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                   KODPOC :<$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/C$> ULICA :<$alltrim(ODN->ULICA)/C$>

                   ANALITYKA :<$KTRHID/XXXXXXXXXX/C$>

 -----------------------------------------------------------------------------------------------------------

^03  ZA CO^04    :<$TKonto/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                   NrFaktury :<$DOKUMFA/XXXXXXXXXXXXXXX/C$> DataFaktury :<$datfakzan/D$>

^03  KWOTA^04    :                                                       ^03<$WNPLN/99,999,999.99/N$> PLN^04

 -----------------------------------------------------------------------------------------------------------

^03  SŁOWNIE^04 :<$slownie(wnpln)/C$>

 -----------------------------------------------------------------------------------------------------------

        Wystawił        Sprawdził       Zatwierdził        Rap.kasowy              Kwotę powyższą otrzymałem

                                                           Nr  ......

                                                           poz ......              .........................

                                                                                <$USERS->usr0/C$>

 -----------------------------------------------------------------------------------------------------------^20

</naglowek.ACH>

</dokument.ACH>

Pozycje raportu kasowego, dowód KW plik KKP001KW.ACH

<dokument.ACH>

<naglowek.ACH>

 -----------------------------------------------------------------------------------------------------------

                                          W1GDOWÓD WYPŁATY KW nr :<$DOKUMZA/XXXXXXXXXXXX/C$> W0H

     . . . . . . . . . . . . . .          Pokwitowanie

               Pieczęć

                                          Dnia <$Date()/####.##.##/D$>

 -----------------------------------------------------------------------------------------------------------

OD KOGO :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  KODPOC :<$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/C$> ULICA :<$alltrim(ODN->ULICA)/C$>

                  ANALITYKA :<$KTRHID/XXXXXXXXXX/C$> EANODN :<$ODN->EANODN/XXXXXXXXXXXXX/C$>

 -----------------------------------------------------------------------------------------------------------

ZA CO   :<$TKonto/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  NrFaktury :<$DOKUMFA/XXXXXXXXXXXXXXX/C$> DataFaktury :<$DATFAKZAN()/XXXXXXXX/D$> Zwłoka :<$ZWLOKAZAN()/99999/I$>

        KWOTA    :<$WNPLN/99,999,999.99/N$> PLN

 -----------------------------------------------------------------------------------------------------------

SŁOWNIE :<$slownie(abs(wnpln))/C$>

 -----------------------------------------------------------------------------------------------------------

        Wystawil        Sprawdzil       Zatwierdzil        Rap.kasowy              Kwotę powyższą otrzymałem

                                                           Nr  ......

                                                           poz ......              .........................

                                                                                podpis kasjera

                                                                                <$USERS->usr0/C$>

 -----------------------------------------------------------------------------------------------------------

</naglowek.ACH>

</dokument.ACH>

Pozycje raportu bankowego, dowód BP plik KKP001BP.ACH

<dokument.ACH>

<naglowek.ACH>

 -----------------------------------------------------------------------------------------------------------

                                          W1GBANKOWE POLECENIE WPLATY nr :<$DOKUMZA/XXXXXXXXXXXX/C$> W0H

     . . . . . . . . . . . . . .          Pokwitowanie

               pieczec

                                          Dnia <$Date()/####.##.##/D$>

 -----------------------------------------------------------------------------------------------------------

OD KOGO :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  KODPOC :<$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/C$> ULICA :<$alltrim(ODN->ULICA)/C$>

                  ANALITYKA :<$KTRHID/XXXXXXXXXX/C$> EANODN :<$ODN->EANODN/XXXXXXXXXXXXX/C$>

 -----------------------------------------------------------------------------------------------------------

ZA CO   :<$TKonto/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  NrFaktury :<$DOKUMFA/XXXXXXXXXXXXXXX/C$> DataFaktury :<$datfakzan/XXXXXXXX/D$> Zwłoka :<$zwlokazan/99999/I$>

        KWOTA    :<$MAPLN/99,999,999.99/N$> PLN

 -----------------------------------------------------------------------------------------------------------

SŁOWNIE :<$slownie(mapln)/C$>

 -----------------------------------------------------------------------------------------------------------

        Wystawil        Sprawdzil       Zatwierdzil        Rap.bankowy              Kwotę powyższą otrzymałem

                                                           Nr  ......

                                                           poz ......              .........................

                                                                                podpis

                                                                                <$USERS->usr0/C$>

 -----------------------------------------------------------------------------------------------------------

</naglowek.ACH>

</dokument.ACH>

Pozycje raportu bankowego, dowód BW plik KKP001BW.ACH

<dokument.ACH>

<naglowek.ACH>

 -----------------------------------------------------------------------------------------------------------

                                          W1BANKOWE POLECENIE WYPLATY KP nr :<$DOKUMZA/XXXXXXXXXXXX/C$> W0H

     . . . . . . . . . . . . . .          Pokwitowanie

               pieczec

                                          Dnia <$Date()/####.##.##/D$>

 -----------------------------------------------------------------------------------------------------------

OD KOGO :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  KODPOC :<$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/C$> ULICA :<$alltrim(ODN->ULICA)/C$>

                  ANALITYKA :<$KTRHID/XXXXXXXXXX/C$> EANODN :<$ODN->EANODN/XXXXXXXXXXXXX/C$>

 -----------------------------------------------------------------------------------------------------------

ZA CO   :<$TKonto/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                  NrFaktury :<$DOKUMFA/XXXXXXXXXXXXXXX/C$> DataFaktury :<$datfakzan/XXXXXXXX/D$> Zwłoka :<$zwlokazan/99999/I$>

        KWOTA    :<$MAPLN/99,999,999.99/N$> PLN

 -----------------------------------------------------------------------------------------------------------

SŁOWNIE :<$slownie(mapln)/C$>

 -----------------------------------------------------------------------------------------------------------

        Wystawil        Sprawdzil       Zatwierdzil        Rap.bankowy              Kwotę powyższą otrzymałem

                                                           Nr  ......

                                                           poz ......              .........................

                                                                                podpis kasjera

                                                                                <$USERS->usr0/C$>

 -----------------------------------------------------------------------------------------------------------

</naglowek.ACH>

</dokument.ACH>


Szablon MPN

F3 Układ tabeli

Typ:MPN Nazwa:WZ/NAGLOWEK/REJLinia Pozyc.Wielk.Opis Format Suma KodSter

------------------------------------------------------------------------

INDEKS :¦1 1 15 INDEKS XXXXXXXXXXXXXXX N

NAZWA :¦1 2 40 NAZWA XXXXXXXXXXXXXXX N

ROZCHOD :¦1 4 11 ROZCHOD 9,999,999.999 N

CENANETTO :¦0 4 9 CENANETTO 999,999.99 N

WARNET :¦0 5 9 WartNetto 999,999.99 T

TAX :¦0 6 3 V 9 N

F5 Atrybuty dokumentu

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦TAK

03 TABELA Ilość egz. :¦ 1

04 Port drukarki :¦1

05 Podgląd (T/N)¦TAK

06 Ilość wierszy :¦ 70

07 WZ Ilość egz. :¦ 1

08 Port drukarki :¦1

09 Podgląd (T/N)¦TAK

10 Ilość wierszy :¦ 70

11 Wydruk au (T/N)¦TAK

12 SWZ Ilość egz. :¦ 0

13 Port drukarki :¦

14 Ilość wierszy :¦ 70

Dokument wydania magazynowego Wz plik MPN00101.ACH

<dokument.ACH>

<naglowek.ACH>

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> UL.<$alltrim(gcUlica)/C$>Nr domu :<$gcDom/XXXXX/C$>

Wydanie Magazynowe Nr WZ :<$DOKUMWZ/XXXXXXXXXXXX/C$>

<$date()/####.##.##/D$>

Data :<$DATFAK/##.##.##/D$> Data Wyst :<$DDOWOD/##.##.##/D$>

EANODN :<$EANODN/XXXXXXXXXXXXX/C$>  NIP :<$NIP/XXXXXXXXXXXXX/C$> ANALITYKA :<$ODN->NRIDODN/XXXXXXXXXXXX/C$>

Odbiorcy :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$KODPOC/99-999/C$> <$alltrim(ODN->MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ULICA :<$ODN->ULICA/C$>

MIEJSCE DOSTAWY:<$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

^04

</naglowek.ACH>

<pozycje.ACH>

----------------------------------------------------------------------------------------------

   Lp. INDEKS             NAZWA                                                       ROZCHOD

----------------------------------------------------------------------------------------------

<NEXT:1>

<$INDEKS/TX_X15/C$><$NAZWAAS/TX_X50/C$><$ROZCHOD/TX_N113/N$>

----------------------------------------------------------------------------------------------

</pozycje.ACH>

<stopka.ACH>

______________________________________________________________________________________________

Objętość:<$_SumObjeWZ()/999,999.99/N$>   Ciężar:<$_SumCiezWZ()/999,999.99/N$>

_______________________________________________________________________________________________

Dokument wystawil : <$USERS->usr0/XXXXXXXXXXXXXX/C$>

</stopka.ACH>

</dokument.ACH>


Szablon MWN

F3 układ tabeli

Typ:MWN Nazwa:PZ/NAGLOWEK/REJLinia Pozyc.Wielk.Opis Format Suma KodSter

------------------------------------------------------------------------

NAZWA :¦1 1 50 Nazwa asortymen XXXXXXXXXXXXXXX N

INDEKS :¦2 1 17 Indeks XXXXXXXXXXXXXXX N

KTM :¦0 2 26 IndeksKraków XXXXXXXXXXXXXXX N

JEDN :¦2 3 14 Jed XXX N

PRZYCHOD :¦1 3 11 Ilość 999,999.999 N

TAX :¦2 4 3 TAX XXX N

CENANETTO :¦1 4 13 Cena netto 99,999,999.99 N

WARNET :¦1 5 13 Wartość netto 99,999,999.99 T

F5 atrybuty dokumentów

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦NIE

03 TABELA Ilość egz. :¦ 1

04 Port drukarki :¦1

05 Podgląd (T/N)¦TAK

06 Ilość wierszy :¦ 0

07 PZ Ilość egz. :¦ 1

08 Port drukarki :¦1

09 Podgląd (T/N)¦TAK

10 Ilość wierszy :¦ 0

11 Wydruk au (T/N)¦nie

12 SPZ Ilość egz. :¦ 0

13 Port drukarki :¦

14 Ilość wierszy :¦ 70

Dokument potwierdzenia dostawy - zakupu plik MPN00101.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> UL.<$alltrim(gcUlica)/C$>

DOWÓD DOSTAWY PZ nr :<$DOKUMWZ/XXXXXXXXXXXX/C$>    Data:<$DDOWOD/##.##.##/D$>

NrFaktDostawcy :<$DOKUMFA/XXXXXXXXXXXXXXX/C$> Data wystawienia:<$DATFAK/##.##.##/D$>

NIP :<$NIP/XXXXXXXXXXXXX/C$> ANALITYKA :<$KTRHID/XXXXXXXXXX/C$>

Odbiorcy :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$KODPOC/99-999/C$> <$alltrim(ODN->MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ULICA :<$ODN->ULICA/C$>^04

</naglowek.ACH>

<pozycje.ACH>

------------------------------------------------------------------------------------------

   Lp. KOD EAN          Nazwa asortymentu                                           Ilość

       Indeks               Jed

------------------------------------------------------------------------------------------

<NEXT:2>

<$EANASN/TX_X13/C$><$NAZWAAS/TX_X50/C$><$PRZYCHOD/999,999.999/N$>

<$INDEKS/TX_X15/C$>  <$JEDN/TX_X3/C$>

------------------------------------------------------------------------------------------

</pozycje.ACH>

<suma.ACH>

Suma NETTO  :<$Vnetto()/99,999,999.99/N$>

Suma VAT    :<$VVAT()/99,999,999.99/N$>

Suma BRUTTO :<$VBRUTTO()/99,999,999.99/N$>

</suma.ACH>

<stopka.ACH>

                                                                                TOWAR PRZYJĄŁ

                                                                      ......................................

Dokument wystawil : <$USERS->usr0/XXXXXXXXXXXXXX/C$>^20

</stopka.ACH>

</dokument.ACH>


Szablon MMN

F3 Układ tabeli

Typ:MMN Nazwa:MM/NAGLOWEK/REJLinia Pozyc.Wielk.Opis Format Suma KodSter

-----------------------------------------------------------------------

INDEKS :¦1 1 15 INDEKS XXXXXXXXXXXXXXX N

NAZWA :¦2 2 40 Nazwa asortymen XXXXXXXXXXXXXXX N

PRZYCHOD :¦1 3 9 PRZYCHOD 999,999.99 N

ROZCHOD :¦1 4 9 ROZCHOD 999,999.999 N

CENANETTO :¦1 5 12 CENANETTO 99,999,999.99 N

WARNET :¦1 6 12 WARNET 99,999,999.99 N

F5 atrybuty dokumentu

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦nie

03 TABELA Ilość egz. :¦ 0

04 Port drukarki :¦1

05 Podgląd (T/N)¦nie

06 Ilość wierszy :¦ 65

07 MM Ilość egz. :¦ 1

08 Port drukarki :¦1

09 Podgląd (T/N)¦TAK

10 Ilość wierszy :¦ 50

11 Wydruk au (T/N)¦TAK

12 SMM Ilość egz. :¦ 1

13 Port drukarki :¦1

14 Ilość wierszy :¦ 70

Dokument wydania magazynowego Rw plik MMN00101.ACH

<dokument.ACH>

<naglowek.ACH>

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/C$> ul.<$alltrim(gcUlica)/C$>

^03

Wydanie z magazynu nr :<$DOKUMWZ/XXXXXXXXXXXX/C$>    Data wystawienia :<$DDOWOD/##.##.##/D$>

Odbiorca :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$KODPOC/99-999/C$> <$alltrim(ODN->MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ULICA :<$ODN->ULICA/C$>

</naglowek.ACH>

<pozycje.ACH>

--------------------------------------------------------------------------------------

   Lp. INDEKS               PRZYCHOD        ROZCHOD        CENANETTO           WARNET

       Nazwa asortymentu

--------------------------------------------------------------------------------------

<NEXT:2>

<$INDEKS/C$><$PRZYCHOD/999,999.99/N$><$ROZCHOD/999,999.999/N$><$CENANETTO/99,999,999.99/N$><$WARNET()/99,999,999.99/N$>

<$NAZWAAS/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

--------------------------------------------------------------------------------------

</pozycje.ACH>

<stopka.ACH>

Dokument wystawił : <$users->usr0/C$>

<$UWAGI1/C$>

<$UWAGI2/C$>

<$UWAGI3/C$>

</stopka.ACH>

</dokument.ACH>

Dokument przychodu wewnętrznego Pw plik MMN001PW.ACH

<dokument.ACH>

<naglowek.ACH>

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/C$> ul.<$alltrim(gcUlica)/C$>

^03

PRZYCHOD WEWNETRZNY 'PW' nr :<$DOKUMWZ/XXXXXXXXXXXX/C$>    Data wystawienia :<$DDOWOD/#

MAGAZYN PRZYJECIA :<$MPRZYJE/XX/C$>

Odbiorca :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$KODPOC/99-999/C$> <$alltrim(ODN->MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

</naglowek.ACH>

<pozycje.ACH>

--------------------------------------------------------------------------------------

Lp. INDEKS               PRZYCHOD        ROZCHOD        CENANETTO           WARNET

Nazwa asortymentu

--------------------------------------------------------------------------------------

<NEXT:2>

<$INDEKS/XXXXXXXXXXXXXXX/C$><$PRZYCHOD/999,999.99/N$><$ROZCHOD/999,999.999/N$><$CENANET

<$NAZWAAS/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

--------------------------------------------------------------------------------------

</pozycje.ACH>

<suma.ACH>

Suma :<$VNETTO()/99,999

</suma.ACH>

<stopka.ACH>

Dokument wystawił : <$users->usr0/C$>

<$UWAGI1/C$>

<$UWAGI2/C$>

<$UWAGI3/C$>

</stopka.ACH>

<koniecstrony.ACH>

^20

</koniecstrony.ACH>

</dokument.ACH>

Dokument przesunięcia międzymagazynowego Mm plik MMN001MM.ACH

<dokument.ACH>

<naglowek.ACH>

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/C$> ul.<$alltrim(gcUlica)/C$>

^03

PRZESUNIĘCIE MAGAZYNOWE nr :<$DOKUMWZ/XXXXXXXXXXXX/C$>    Data wystawienia :<$DDOWOD/##.##.##/D$>

MAGAZYN WYDANIA:<$MAGAZYN/XX/C$>     MAGAZYN PRZYJECIA :<$MPRZYJE/XX/C$>

Odbiorca :<$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$KODPOC/99-999/C$> <$alltrim(ODN->MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ULICA :<$ODN->ULICA/C$>

</naglowek.ACH>

<pozycje.ACH>

--------------------------------------------------------------------------------------

   Lp. INDEKS               PRZYCHOD        ROZCHOD        CENANETTO           WARNET

       Nazwa asortymentu

--------------------------------------------------------------------------------------

<NEXT:2>

<$INDEKS/C$><$PRZYCHOD/999,999.99/N$><$ROZCHOD/999,999.999/N$><$CENANETTO/99,999,999.99/N$><$WARNET()/99,999,999.99/N$>

<$NAZWAAS/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

--------------------------------------------------------------------------------------

</pozycje.ACH>

<suma.ACH>

                                                                Suma :<$VNETTO()/99,999,999.99/N$>

</suma.ACH>

<stopka.ACH>

Dokument wystawił : <$users->usr0/C$>

UWAGI:

<$UWAGI1/C$>

<$UWAGI2/C$>

<$UWAGI3/C$>

</stopka.ACH>

<koniecstrony.ACH>

^20

</koniecstrony.ACH>

</dokument.ACH>


Szablon OFN

F3 układ tabeli

Typ:OFN Nazwa:/ZAMOWIENIA/ODBLinia Pozyc.Wielk.Opis Format Suma KodSter

-----------------------------------------------------------------------

INDEKS :¦2 1 20 INDEKS XXXXXXXXXXXXXXX N

NAZWA :¦1 1 41 Nazwa asortymen XXXXXXXXXXXXXXX N

UwagiLinia1 :¦0 1 20 UwagiLinia1 XXXXXXXXXXXXXXX N

JEDN :¦1 2 3 J.m XXX N

SWW :¦2 2 49 PKWiU(SWW) XXXXXXXXXXXXXX N

RABAT :¦0 3 5 RABAT 99,999,999.99 N

CENANETTO :¦2 3 12 P.Raba 99,999,999.99 N

ROZCHOD :¦1 3 5 Ilość 999999999999 N

PROCRAB :¦2 4 5 %Raba 99.99 N

CENAREAL :¦1 5 12 Cena netto 99,999,999.99 N

TAX :¦2 5 3 VAT !!! N

WARNET :¦1 6 12 Wart.netto 99,999,999.99 N

WARBRU :¦1 8 13 Wart.brutto 99,999,999.99 N

F5 atrybuty dokumentu

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦TAK

03 TABELA Ilość egz. :¦ 0

04 Port drukarki :¦

05 Podgląd (T/N)¦nie

06 Ilość wierszy :¦ 0

07 ZAMOWIENIA/01 Ilość egz. :¦ 1

08 Port drukarki :¦1

09 Podgląd (T/N)¦TAK

10 Ilość wierszy :¦ 60

11 Wydruk au (T/N)¦TAK

12 ZAMOWIENIA/02 Ilość egz. :¦ 1

13 Port drukarki :¦2

14 Podgląd (T/N)¦TAK

15 Ilość wierszy :¦ 65

16 SZAMOWIENIA/01 Ilość egz. :¦ 0

17 Port drukarki :¦

18 Ilość wierszy :¦ 0

19 SZAMOWIENIA/02 Ilość egz. :¦ 0

20 Port drukarki :¦

21 Ilość wierszy :¦ 0

Potwierdzenie przyjęcia zamówienia od odbiorcy plik OFN00101.ACH

<dokument.ACH>

<naglowek.ACH>

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/C$> ul.<$alltrim(gcUlica)/C$>

^03

^07POTWIERDZENIE ZAMÓWIENIA nr :<$substr(NRZAMOW,1,8)/C$>/<$KODHAND/XX/C$> ^04^03      ORYGINAŁ / KOPIA

^04           Data wystawienia :<$DDOWOD/##.##.##/D$>

<$REPL("-",70)/C$>

  KLIENT Data/Numer zamówienia : <$ZAMOWIENIE/C$>

            Data Realizacji :<$TERMINRE/##.##.##/D$>  Tydzień :<$TYDZIEN/99/C$>

NABYWCA :<$ODN->NAZWA1/C$>

         <$ODN->NAZWA2/C$>

         <$ODN->KODPOC/99-999/C$><$alltrim(MIEJSC)/C$> ul.<$alltrim(ODN->ULICA)/C$>

    NIP :<$ODN->NIP/C$>  ANALITYKA:<$KTRHID/XXXXXXXXXXC$>

ODBIORCA:<$SKROCO/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$setODNMDN()/!/C$>

MIEJSCE DOSTAWY : <$MDN->KODPOC/99-999/C$><$ALLTRIM(MDN->MIEJSC)/C$>ul.<$alltrim(MDN->MIEJSCDOST)/C$>

                  <$MDN->ULICA/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

SPOSÓB DOSTAWY  : <$SDOSTAWY/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

UWAGI           : <$UWAGI1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

^02

</naglowek.ACH>

<pozycje.ACH>

---------------------------------------------------------------------------------

   Lp. Nazwa asortymen                                       J.m           Ilość

       IND.KLIENTA   KOD EAN          INDEKS NASZ

---------------------------------------------------------------------------------

<NEXT:2>

<$NAZWAAS/TX_X50/C$><$JEDN/TX_X3/C$><$ROZCHOD/999999999999/N$>

<$ADRES/TX_X10/C$><$EANASN/TX_X13/C$><$INDEKS/TX_X15/C$>

---------------------------------------------------------------------------------

</pozycje.ACH>

<poczatekstrony.ACH>

</poczatekstrony.ACH>

<sumafaktury.ACH>

-------------------------------------------------------

-------------------------------------------------------

</sumafaktury.ACH>

<koniecstrony.ACH>

^20

</koniecstrony.ACH>

<stopka.ACH>

                                                                       Wystawił :

<$ODN->NAZWDOK/C$>

.......................................                          <$USERS->usr0/C$>

</stopka.ACH>

<system.ACH>

</system.ACH>

</dokument.ACH>


Szablon OHN

F3 układ tabeli

Typ:OHN Nazwa:/ZAMOWIENIA/DOSLinia Pozyc.Wielk.Opis Format Suma KodSter

-----------------------------------------------------------------------

INDEKS :¦1 1 15 Indeks XXXXXXXXXXXXXXX N

NAZWA :¦2 1 50 Nazwa asortymen XXXXXXXXXXXXXXX N

KTM :¦0 2 12 IndeksKraków XXXXXXXXXXXXXXX N

PRZYCHOD :¦1 3 11 Ilość 9,999,999.999 N

JEDN :¦1 4 3 JED XXXXXXXXXX N

F5 atrybuty dokumentu

01 Domyślny typ drukarki :¦01

02 Możliwość zmiany drukarki (T/N)¦nie

03 TABELA Ilość egz. :¦ 1

04 Port drukarki :¦1

05 Podgląd (T/N)¦nie

06 Ilość wierszy :¦ 65

07 ZAMOWIENIA/01 Ilość egz. :¦ 1

08 Port drukarki :¦1

09 Podgląd (T/N)¦TAK

10 Ilość wierszy :¦ 56

11 Wydruk au (T/N)¦TAK

12 ZAMOWIENIA/02 Ilość egz. :¦ 1

13 Port drukarki :¦1

14 Podgląd (T/N)¦TAK

15 Ilość wierszy :¦ 56

16 SZAMOWIENIA/01 Ilość egz. :¦ 0

17 Port drukarki :¦

18 Ilość wierszy :¦ 0

19 SZAMOWIENIA/02 Ilość egz. :¦ 0

20 Port drukarki :¦

21 Ilość wierszy :¦ 0

Zamówienie do dostawcy np. w wersji angielskojęzycznej plik OHN00101.ACH

<dokument.ACH>

<naglowek.ACH>

^01

^03BUYER:

<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

<$gcKodPoc/XXXXXX/C$> <$alltrim(gcMiejsc)/C$> ul.<$alltrim(gcUlica)/C$>

TEL/FAX : (+48/61)857-41-67/77 faks 857-41-86

  EMAIL : stiga@stiga.com.pl

^03ORDER NUMBER :<$SUBSTR(NRZAMOW,1,8)/C$> DATE:<$DATZAM/##.##.##/D$>

DELIVERY DATE:<$TERMINRE/##.##.##/D$>  WEEK OF DELIVERY :<$TYDZIEN/99/C$>

DATE/ORDER NUMBER:<$ZAMOWIENIE/C$>

SUPPLIER: <$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$alltrim(MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> <$alltrim(ODN->ULICA)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

PLACE OF DELIVERY:

NOTE    : <$uwagi1/C$>

^02

</naglowek.ACH>

<pozycje.ACH>

----------------------------------------------------------------------------------------------

   Lp. Art.No             DESCRIPTION                                                Quantity

----------------------------------------------------------------------------------------------

<NEXT:1>

<$INDEKS/TX_X15/C$><$NAZWAAS/TX_X50/C$><$PRZYCHOD/TX_N113/N$>

----------------------------------------------------------------------------------------------

</pozycje.ACH>

<poczatekstrony.ACH>

                                                      <$_nStrona()/XXXXXXX/C$>

</poczatekstrony.ACH>

<stopka.ACH>

Signature

..........................................                            .......................................

<$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXX/C$>

CONFIRMATION OF DELIVERY FROM :<$ODN->NAZWA1/C$>

</stopka.ACH>

<naglowekstrony.ACH>

^03ZAMAWIAJĄCY :<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                <$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                <$alltrim(gcKodPoc)/XXXXXX/C$> <$alltrim(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                <$alltrim(gcUlica)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> <$alltrim(gcDom)/XXXXX/C$>

       NIP  :<$ZUA->DIPL01/XXXXXXXXXXXXX/C$>^04

    TEL/FAX :<$alltrim(ZUA->ASZP07)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$><$alltrim(ZUA->ASZP08)/C$>

       EMAIL:<$ZUA->ASZP09/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

       BANK :<$rtrim(ZUA->BANK00)/C$><$rtrim(ZUA->BANK01)/XXXXXXXX/C$>-<$rtrim(ZUA->BANK02)/C$>

^03

</naglowekstrony.ACH>

<koniecstrony.ACH>

^20

</koniecstrony.ACH>

</dokument.ACH>

Zamówienie do dostawcy np. w wersji polskojęzycznej plik OHN00102.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02

^03ZAMAWIAJĄCY : <$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                <$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                <$alltrim(gcKodPoc)/XXXXXX/C$> <$alltrim(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                <$alltrim(gcUlica)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> <$alltrim(gcDom)/XXXXX/C$>

          NIP : <$ZUA->DIPL01/XXXXXXXXXXXXX/C$>

         BANK :<$trim(ZUA->BANK00)/XXXXXXXXXXXXXXXXXXXX/C$><$trim(ZUA->BANK01)/XXXXXXXX/C$>-<$trim(ZUA->BANK02)C$>

      TEL/FAX :<$alltrim(ZUA->ASZP07)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$><$alltrim(ZUA->ASZP08)/C$>

        EMAIL :<$ZUA->ASZP09/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

^03ZAMÓWIENIE nr :<$NRZAMOW/XXXXXXXXXXXXXXX/C$>

DOSTAWCA: <$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->KODPOC/99-999/C$> <$alltrim(MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ul.<$alltrim(ODN->ULICA)/C$>

    NIP : <$ODN->NIP/XXXXXXXXXXXXX/C$>       MAGAZYN :<$MAGAZYN/XX/C$>

^04

^02

</naglowek.ACH>

<pozycje.ACH>

----------------------------------------------------------------------------------------------------------------------------

   Lp. Nazwa asortymentu                                           Ilość       Cena netto    Wartość netto    VAT

       SWW/PKWiU                                                            Jed    %Raba     Kwota rabatu

----------------------------------------------------------------------------------------------------------------------------

<NEXT:2>

<$NAZWAAS/C$><$ROZCHOD/999,999.999/N$><$CENANETTO/99,999,999.99/N$><$WARNET()/99,999,999.99/N$><$TAX()/XXX/C$>

<$SWW/XXXXXXXXXXXXXX/C$>                                      <$JEDN/XXX/C$><$PROCRAB/99.99/N$><$RABAT()/99,999,999.99/N$>

---------------------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<poczatekstrony.ACH>

                                                      <$_nStrona()/XXXXXXX/C$>

</poczatekstrony.ACH>

<stopka.ACH>

ZAMÓWIENIE WYSTAWIL                                                 TOWAR PRZYJAL ZGODNIE ZE SPECYFIKACJA

..........................................                            .......................................

<$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXX/C$>

</stopka.ACH>

<koniecstrony.ACH>

^20

</koniecstrony.ACH>

</dokument.ACH>


Szablon RPN

Dokument polecenie księgowania plik RPN00101.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02

NUMER<$TYPDOK/XX/C$>:<$NUMERPK/XXXXXXXXXXXX/C$>

OBROTYWN :<$WNPK()/99,999,999.99/N$>

OBROTYMA :<$MAPK()/99,999,999.99/N$>

SALDO :<$SALDOPK()/99,999,999.99/N$>

TRESC :<$TKONTO/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

</naglowek.ACH>

<pozycje.ACH>

----------------------------------------------------------------------------------------------------------------

   Lp. NrDowodu           Tresc                             KontoWN     KontoMA             Kwota    Analityka

       NrFaktury          Data

----------------------------------------------------------------------------------------------------------------

<NEXT:2>

<$DOKUMDW/TX_X15/C$><$TRESC/TX_X30/C$><$KWN/XXX-XX-X/C$><$KMA/XXX-XX-X/C$><$KWOTA/TX_N112/N$><$KTRHID/TX_X10/C$>

<$dokum/TX_X15/C$><$DDOWOD/TX_DATA/D$>

----------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

</dokument.ACH>


Szablon KWN

Wezwania do zapłaty typ 1 plik KWN001W1.ACH

typ 2 plik KWN001W2.ACH

typ 3 plik KWN001W3.ACH

typ 4 plik KWN001W4.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02

                     ^05 WEZWANIE DO ZAPŁATY  I

                 ^05 z dnia: <$DDOWOD/##.##.##/D$>

^03 NAZWA WIERZYCIELA:

          <$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$alltrim(gcKodPoc)/XXXXXX/C$> <$alltrim(gcMiejsc)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$alltrim(gcUlica)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> <$alltrim(gcDom)/XXXXX/C$>

 TEL/FAX :<$alltrim(ZUA->ASZP07)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$><$alltrim(ZUA->ASZP08)/C$>

    EMAIL:<$ZUA->ASZP09/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

 ^03 NAZWA DŁUŻNIKA:

          <$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

          <$ODN->KODPOC/99-999/C$> <$alltrim(MIEJSC)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$> ul.<$alltrim(ODN->ULICA)/C$>

  ^04

Na podstawie art. 455 i 476 kodeksu cywilnego wzywamy do uregulowania należnej nam kwoty

wg poniższego obliczenia.

</naglowek.ACH>

<pozycje.ACH>

--------------------------------------------------------------------------------------------------------

   Lp. NrFaktury          DataFakt      Suma Brutto        Zapłacono       Do zapłaty    SP    Termin

--------------------------------------------------------------------------------------------------------

<NEXT:1>

<$DOKUMFA/TX_X15/C$><$DATFAK/TX_DATA/D$><$VBRUTTO/TX_N112/N$><$ZAP0112/TX_N112/N$><$SALDO/TX_N112/N$><$KODWPLATY/TX_X2/C$><$TERMINFA/TX_DATA/D$>

--------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<suma.ACH>

^05 SUMA NALEŻNA DO UREGULOWANIA :<$SALDOWEZ()/99,999,999.99/N$>

</suma.ACH>

<stopka.ACH>

 Wymienioną kwotę prosimy przekazać na nasz rachunek:<$rtrim(ZUA->BANK00)/C$><$rtrim(ZUA->BANK01)/C$><$rtrim(ZUA->BANK02)/C$>

 w ciągu 7 dni od daty otrzymania niniejszego wezwania. W przypadku nie przekazania należnej nam kwoty

 sprawę skierujemy na drogę postępowania sądowego bez ponownego wezwania do zapłaty.

  sporządził/a                                    zatwierdził/a

<$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^20

</stopka.ACH>

</dokument.ACH>


Szablon KSN

Noty odsetkowe plik KSN00101.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02

===============================================================================================================

^05NOTA ODSETKOWA ^06nr<$NRNOTY/XXXXXXXXXXXXXXX/C$>z dnia<$Date()/####.##.##/D$>

===============================================================================================================

NADAWCA:

    ^05<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^06

    ^05<$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^06

    ^05  ul.<$alltrim(gcUlica)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$><$alltrim(gcDom)/XXXXX/C$>/<$gcLokal/XXXXX/C$>^06

    ^05<$gcKodPoc/XXXXXX/C$><$gcMiejsc/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^06

                ADRESAT:

                    <$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                    <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                      ul.<$ULICA/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                    <$ODN->KODPOC/99-999/C$><$MIEJSC/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                      ANALITYKA :<$KTRHID/XXXXXXXXXX/C$>

Na podstawie kodeksu cywilnego wzywamy do uregulowania odsetek za zwłokę według podanego niżej obliczenia.

Wymienioną kwotę prosimy przekazać na nasz rachunek:<$alltrim(ZUA->BANK00)/C$><$alltrim(ZUA->BANK01)/C$>-<$alltrim(ZUA->BANK02)/C$>

w ciągu 7 dni od daty otrzymania niniejszego wezwania.

W przypadku nie przekazania należnej nam kwoty sprawę skierujemy na drogę postępowania sądowego

bez ponownego wezwania.

</naglowek.ACH>

<pozycje.ACH>

---------------------------------------------------------------------------------------------------------------

   Lp. NrFaktury          NrDowodu           TermPłat    DataZapł           WpłataWn    Zwłok          ODSETKI

---------------------------------------------------------------------------------------------------------------

<NEXT:1>

<$DOKUMFA/TX_X15/C$><$DOKUMZA/TX_X12/C$>   <$TERMINZAN/TX_DATA/D$><$DDOWOD/TX_X8/D$>  <$WNPLN/TX_N112/N$><$ZWLOKAZAN/TX_N05/I$><$ODSETKZAN/TX_N112/N$>

---------------------------------------------------------------------------------------------------------------

</pozycje.ACH>

<suma.ACH>

^05Suma odsetek:<$ODSETWEZ()/99,999,999.99/N$>^06

</suma.ACH>

<stopka.ACH>

  Wystawił/a                                               Zatwierdził/a

  ..........................                               ..........................

<$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^20

</stopka.ACH>

</dokument.ACH>


Szablon PSN

Potwierdzenia sald plik PSN00101.ACH

<dokument.ACH>

<naglowek.ACH>

^01^02

=========================================================================================

^05POTWIERDZENIE SALDA^06 wg stanu na dzień :<$TERMINFA/##.##.##/D$>         odcinek ^05A^06

=========================================================================================

NADAWCA:

    ^05<$gcNazwa1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^06

    ^05<$gcNazwa2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^06

    ^05  ul.<$alltrim(gcUlica)/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$><$alltrim(gcDom)/XXXXX/C$>/<$gcLokal/XXXXX/C$>^06

    ^05<$gcKodPoc/XXXXXX/C$><$gcMiejsc/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^06

                ADRESAT:

                    <$ODN->NAZWA1/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                    <$ODN->NAZWA2/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                      ul.<$ULICA/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                    <$ODN->KODPOC/99-999/C$><$MIEJSC/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>

                      ANALITYKA :<$KTRHID/XXXXXXXXXX/C$>

----------------------------------------------------------------------------------------

Na podstawie art. 26 Ustawy z dnia 29 września 1994r. o rachunkowości

(Dz.U. nr 121 a dnia 19.11.1994r., poz.591) uorzejmie prosimy

o pisemne potwierdzenie - ustosunkowanie się na odcinku B

do wskazanych sald w terminie 10 dni.

</naglowek.ACH>

<pozycje.ACH>

----------------------------------------------------------------------------------------

   Lp. NrFaktury          NrDokumentu        DatFakt          Kwota WN         Kwota MA

----------------------------------------------------------------------------------------

<NEXT:1>

<$DOKUMFA/C$><$DOKUMZA/C$>   <$DDOWOD/XXXXXXXX/D$><$WNPLN/99,999,999.99/N$><$MAPLN/99,999,999.99/N$>

----------------------------------------------------------------------------------------

</pozycje.ACH>

<suma.ACH>

Saldo na dobro nasze: ^05<$SALDONOT/99,999,999.99/N$>^06

</suma.ACH>

<stopka.ACH>

  Wystawił/a                                               Zatwierdził/a

  ..........................                               ..........................

<$USERS->usr0/XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/C$>^20

</stopka.ACH>

</dokument.ACH>